Jump to content

FEA Import GOM-ANSYS Error


Recommended Posts

---

Hello,

I want to use the FEA import package to compare GOM measurement and Ansys simulation. When I import FEA results as a surface component in GOM Correlate, an error occurs and stops the import so I can't compare values. Screenshot error is attached.

I synchronized both data stages and aligned Nominal and Actual data as shown in the Webinar but I can't compare go further.

Does someone knows about the origin or already has dealt with this issue ?

 

Thank you,

Lucas

FEA import error.PNG

Link to post
Share on other sites
---

Thank you for providing the screenshot.

The error means: no node coordinates were read from the FEA files.

So the question is: how did you generate the FEA files from ANSYS? Did you use the GOM Interface App provided by CADFEM? Which entity did you select to export? Can you provide the FEA files to have a look at? If not, can you share at least a snapshot of the FEA files in a file explorer to see file size and naming and provide a screenshot of the FEA files opened in a text editor at some interesting locations (surrounding lines at lines starting with *NODE, or with * or $ in general)?

Link to post
Share on other sites
---

I made my model with ANSYS Workbench 17.1 and I exported results with GOM Interface App (*.a2g files).

Files are attached here :

- export_0.a2g contains initial mesh data with *NODE and *ELEMENT

- export_1_1.a2g is supposed to contain nodal displacements but it seems empty..

export_0.a2g export_1_1.a2g

Link to post
Share on other sites
---
Posted (edited)

Thanks for providing your *.a2g files. You are right. Somehow there are no nodal displacements in export_1_1.a2g. Do you get any results / color plots / exaggerated deformation when you analyze your part in ANSYS Workbench -> Mechanical for displacement? Do you have other computation steps? You can select to export data for all computation steps, so if you have a iterative nonlinear calculation maybe other computations steps contain displacement? Or did you switch off displacements in your model somehow?

It is hard to analyze for me, as I am no ANSYS expert and have no access to an ANSYS license to check which circumstances may lead to such a situation. But I would try to play around with settings of the GOM Interface App and / or of your model, calculation and analysis...

Edited
Link to post
Share on other sites
---
Posted (edited)

Thanks for your quick answers !

I can have displacements, strains, stresses... all results and plots in my ANSYS static structural solution. Even with many computation steps I only have those two files (***_0.a2g and ***_1_1.a2g) created and the second one is always empty...

I will try to uninstall and reinstall GOM Interface App on Ansys.

Does this app needs something special such as internet connection, boundary conditions defined only as force or displacement...? Maybe it does not match with ANSYS 17.1 version ?

Edited
Link to post
Share on other sites
  • 3 weeks later...
---

Well, that's strange. The GOM Interface App was introduced in 2017 so it should run in ANSYS 17.

In the GOM Interface App properties you can set if you want to export all steps and all sub-steps. But your file naming *_1_1.a2g already suggests, this is the first substep of the first step. So the App seems to stop working/crash for some reason. Did you get the App from the ANSYS App store? So I guess you must ask CADFEM Suisse, the developer of the App, for further support.

Link to post
Share on other sites
---
Posted (edited)

Indeed, the issue comes from the ANSYS version used to run the GOM Interface App. I try to run it with ANSYS 17.1 and ANSYS 2021 but it doesn't work.

Then, I downloaded the 2019 R1 version and the app is working well, node displacements are written in text file and the import in GOM Correlate Pro doesn't show any error.

Thank you for your help

 

Edited
Link to post
Share on other sites
×
×
  • Create New...